社員ブログ
HOME  社員ブログ

アーカイブ

‘Linux’ カテゴリ

ALMinium のインストールを各OSで試してみました

2014年06月10日 22時02分10秒

こんにちは、ピーターです。

ALMinium のインストールを各OSで試してみました。

スクリーンショット 2014-06-08 16.51.43

動作環境

RHEL6 x64互換環境(OEL,SL,CentOSなど含む)
Ubuntu 12.04(x64)
Amazon AMI Linux 2011.09

 

結果:

CentOS 6.5 インストール失敗
CentOS 6.4 インストール失敗
CentOS 6.3 インストール失敗
CentOS 6.2 インストール失敗
CentOS 6.1 インストール失敗
CentOS 6.0 インストール失敗
Ubuntu 14.04 インストール失敗
Ubuntu 12.04.4 インストール成功

各isoファイルをダウンロードし、VMWare Fusion 6で仮想マシンを新規作成(Linux 簡易インストール)して試しました。
i386が32ビット版で、amd64とx86_64が64ビット版です。
ALMinium は64ビット版を使います。

ご覧の通り、Ubuntu 12.04.4  しかインストールに成功しませんでした。
どうしたら CentOS でインストールが成功するのでしょうか。

ALMinium を git clone して、git tag / git checkout で最新のリリースに切り替えて実行すると説明している記事がありますが、そうすると今はうまくいかない気がします。

ALMinium の現時点(2014年6月10日)の最新リリースは v2.2.4-4 ですが、リリース日が Jun 9, 2013 と1年前です。masterブランチの最新コミットは May 28, 2014 です。

Ubuntu 12.04.4 のインストール成功は、README の通り、masterブランチ の HEAD で bash ./smelt してうまくいきました。v2.2.4-4 に切り替えて実行した場合はうまくいきませんでした。

実際に使用したコマンドはこちらです。

CentOS:

su -
yum install git
git clone https://github.com/alminium/alminium.git
cd alminium
bash ./smelt

Ubuntu:

sudo apt-get install git
git clone https://github.com/alminium/alminium.git
cd alminium
sudo bash ./smelt

 

この後いくつか聞かれますのでこのようにしました。

ホスト名: ifconfigで調べたIPアドレス
SSL: N
メール設定: N
Jenkins: N
セキュリティ(CentOSのみ): Y
MySQLのパスワード(Ubuntuのみ): 空欄


Linux, 社員:ピーター

またずいぶんかかりました。

2014年03月14日 0時26分25秒

 

kijitoranekoです。

こんにちは。

 

昨日消してしまったプロビジョン用のシェルを作りなおしました。

MySqlは5.6にしましたら、またいろいろ起動しない的な問題もありましたが、

スワップのメモリエラー的なものでした。なんとかOK。

 

これで一応Vagrant upしたら、CentOS仮想化を作って、

追加リポジトリ(epel&remi&ius)をインストール後、

ApacheとvimとPHPとMysqlのダウンロード&インストールまで、自動化しました。

リポジトリの参照ポリシーもちゃんと決めないとね。

 

あとは必要なものをシェルに追加していけばいいかな。

そのうちChefに移行しましょう。

 

Vagrantの全仮想マシンでの共通の設定は「$HOME/.vagrant.d/Vagrantfile」を参照するようです。

ですので、こちらに共通の設定は書くようにします。

それとプロビジョニング設定はVagrantfileのどっかに以下のように

config.provision “shell”, path: “provision.sh”

 

もう寝ます。

ではまた。

 


CentOS, Linux, Macintosh, 社員:kijitoraneko

Raspberry Piとりあえず動いた。

2014年02月18日 11時36分41秒

こんにちは、カズマです。

 

ちょくちょくいじっているRaspberry PiにやっとOSがインストールされました。

まぁをみてやっているだけなのですけど。

 

①一先ず電源入れて。

Raspberry Pi起動

 

②本にいいなりにセットアップしていくー

インストール

 

③そしたらとりあえず動いた。

デスクトップ

これでやっとスタート地点・・・。

 

画面キャプチャが使えないので、全部カメラになってしまう・・・。

手順を教えてくれるサイトでは、どのようにしているのだろうか。

やっぱりデジカメなのでしょうかね。


Linux, 社員:カズマ, 雑記